<!DOCTYPE html>
<!--[if IE 8]><html class="ie8"><![endif]-->
<!--[if IE 9]><html class="ie9"><![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US" prefix="og: http://ogp.me/ns#"> <!--<![endif]-->
<head><meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<script data-cfasync='false' data-pagespeed-no-defer>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</script><script data-cfasync='false' data-pagespeed-no-defer>__ez.pel=function(){function c(a,b){d(a,b,0,0,0,0,0),f()}function d(b,c,d,e,f,h,i){if(__ez.dot.isDefined(b,b.getSlotElementId)){var j=parseInt(b.getTargeting("ap")[0]),k=b.getSizes()[0],l=k.l.toString()+"x"+k.j.toString(),m=g(b),n=b.getSlotElementId();__ez.dot.isDefined(m,n)&&__ez.dot.isValid(c)&&a.push({type:"impression",impression_id:m,domain_id:__ez.dot.getDID(),unit:n,t_epoch:__ez.dot.getEpoch(0),revenue:d,est_revenue:e,ad_position:j,ad_size:l,bid_floor_filled:f,bid_floor_prev:h,stat_source_id:i,country_code:__ez.dot.getCC(),data:__ez.dot.dataToStr(c)})}}function e(b,c){var d=b.split("/");if(__ez.dot.isDefined(b)&&3===d.length&&__ez.dot.isValid(c)){var e=d[0],f=d[2];a.push({type:"impression",impression_id:f,domain_id:__ez.dot.getDID(),unit:e,t_epoch:__ez.dot.getEpoch(0),data:__ez.dot.dataToStr(c)})}}function f(){void 0!==document.visibilityState&&"prerender"===document.visibilityState||(__ez.dot.isDefined(a)&&a.length>0&&((new Image).src=__ez.dot.getURL(b)+"?orig="+(!0===__ez.template.isOrig?1:0)+"&sts="+btoa(JSON.stringify(a))),a=[])}function g(a){var b=0;try{var c=a.getTargetingMap();if(-1===a.getSlotElementId().indexOf("div-gpt-ad"))return b;if(void 0!==c)for(var e in c)if(-1!==e.indexOf("iid")&&void 0!==c[e][0]){b=c[e][0];break}}catch(a){}return b}var a=[],b="/porpoiseant/army.gif";return{Add:d,AddAndFire:c,AddById:e,Fire:f}}();var EzoicPixel=function(){this.pixels=[],this.pixelUrl="/ezoic/e.gif",("undefined"!=typeof ezJsu&&!0===ezJsu||"undefined"!=typeof _ez_sa&&!0===_ez_sa||void 0!==window.isAmp&&!0===isAmp||"undefined"!=typeof ezWp&&!0===ezWp)&&(this.pixelUrl="//g.ezoic.net"+this.pixelUrl),this.tEpoch=0,"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("t_epoch")&&(this.tEpoch=_ezaq.t_epoch)},EzoicPixelData=function(i,e){this.name=i,this.val=e};EzoicPixel.prototype={constructor:EzoicPixel,AddAndFireImpPixel:function(i,e){this.AddImpPixel(i,e,0,0,0,0,0),this.FirePixels()},AddAndFirePVPixel:function(i,e){this.AddPVPixel(i,e),this.FirePixels()},AddImpPixel:function(i,e,t,n,o,a,r){if(this.isDefined(i,i.getSlotElementId)){var d=parseInt(i.getTargeting("ap")[0]),s=i.getSizes()[0],p=s.l.toString()+"x"+s.j.toString(),l="0",h="XX";"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("domain_id")&&(l=_ezaq.domain_id.toString()),"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("country")&&(h=_ezaq.country);var f=this.getSlotIID(i),c=i.getSlotElementId();this.isDefined(f,c)&&this.validateData(e)&&(e=this.convertDataToStr(e),this.pixels.push({type:"impression",impression_id:f,domain_id:l,unit:c,t_epoch:this.tEpoch,revenue:t,est_revenue:n,ad_position:d,ad_size:p,bid_floor_filled:o,bid_floor_prev:a,stat_source_id:r,country_code:h,data:e}))}},AddImpPixelById:function(i,e){var t="0";"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("domain_id")&&(t=_ezaq.domain_id.toString());var n=i.split("/");if(this.isDefined(i)&&3===n.length&&this.validateData(e)){var o=n[0],a=n[2];e=this.convertDataToStr(e),this.pixels.push({type:"impression",impression_id:a,domain_id:t,unit:o,t_epoch:this.tEpoch,data:e})}},AddPVPixel:function(i,e){var t="0";"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("domain_id")&&(t=_ezaq.domain_id.toString()),this.isDefined(i)&&this.validateData(e)&&(e=this.convertDataToStr(e),this.pixels.push({type:"pageview",pageview_id:i,domain_id:t,t_epoch:this.tEpoch,data:e}))},FirePixels:function(){void 0!==document.visibilityState&&"prerender"===document.visibilityState||(this.isDefined(this.pixels)&&this.pixels.length>0&&((new Image).src=this.pixelUrl+"?orig="+(!0===__ez.template.isOrig?1:0)+"&pixels="+encodeURIComponent(JSON.stringify(this.pixels))),this.pixels=[])},NewData:function(i,e){return new EzoicPixelData(i,e)},convertDataToStr:function(i){if(void 0===i)return[];try{for(var e in i)i[e].val=i[e].val+""}catch(i){}return i},getSlotIID:function(i){var e=0;try{var t=i.getTargetingMap();if(-1===i.getSlotElementId().indexOf("div-gpt-ad"))return e;if(void 0!==t)for(var n in t)if(-1!==n.indexOf("iid")&&void 0!==t[n][0]){e=t[n][0];break}}catch(i){}return e},isDefined:function(){for(var i=0;i<arguments.length;i++)if(void 0===arguments[i]||null===arguments[i])return console.error("Argument not defined. ",arguments),!1;return!0},validateData:function(i){for(var e=0;e<i.length;e++)if(i[e]instanceof EzoicPixelData==!1)return console.error("Invalid pixelData. ",i[e]),!1;return!0}};</script>
<meta name="verifyownership" content="f35a686a9ce8d82382e091b96fb61dc6" />

<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-P6XN5Z6');</script>

<meta name="viewport" content="user-scalable=yes, width=device-width, initial-scale=1.0, maximum-scale=1, minimum-scale=1">
<!--[if lt IE 9]>
	<script src="https://linuxhint.com/wp-content/themes/voice/js/html5.js"></script>
<![endif]-->
<title>Installing Android on VirtualBox | Linux Hint</title>

<meta name="description" content="An efficient way of installing Android is on your VirtualBox which takes away one of the sluggiest aspect of Android development -- The device emulator. You can use this VM to run your test application or just fiddle with Android’s internals." />
<link rel="canonical" href="https://linuxhint.com/install_android_virtualbox/" />
<link rel="publisher" href="https://plus.google.com/+linuxhint" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Installing Android on VirtualBox | Linux Hint" />
<meta property="og:description" content="An efficient way of installing Android is on your VirtualBox which takes away one of the sluggiest aspect of Android development -- The device emulator. You can use this VM to run your test application or just fiddle with Android’s internals." />
<meta property="og:url" content="https://linuxhint.com/install_android_virtualbox/" />
<meta property="og:site_name" content="Linux Hint" />
<meta property="article:publisher" content="https://www.facebook.com/LinuxHint-1321325764663109" />
<meta property="article:section" content="Android" />
<meta property="article:published_time" content="2018-08-04T02:33:48-07:00" />
<meta property="article:modified_time" content="2018-08-06T07:43:42-07:00" />
<meta property="og:updated_time" content="2018-08-06T07:43:42-07:00" />
<meta property="og:image" content="https://linuxhint.com/wp-content/uploads/2018/08/android_virtualbox.png" />
<meta property="og:image:secure_url" content="https://linuxhint.com/wp-content/uploads/2018/08/android_virtualbox.png" />
<meta property="og:image:width" content="495" />
<meta property="og:image:height" content="268" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="An efficient way of installing Android is on your VirtualBox which takes away one of the sluggiest aspect of Android development -- The device emulator. You can use this VM to run your test application or just fiddle with Android’s internals." />
<meta name="twitter:title" content="Installing Android on VirtualBox | Linux Hint" />
<meta name="twitter:site" content="@linuxhint" />
<meta name="twitter:image" content="https://linuxhint.com/wp-content/uploads/2018/08/android_virtualbox.png" />
<meta name="twitter:creator" content="@linuxhint" />
<script type='application/ld+json'>{"@context":"https:\/\/schema.org","@type":"Organization","url":"https:\/\/linuxhint.com\/","sameAs":["https:\/\/www.facebook.com\/LinuxHint-1321325764663109","https:\/\/plus.google.com\/+linuxhint","https:\/\/www.youtube.com\/channel\/UCHErB0TULAlldbhPMfBJ1Xg","https:\/\/twitter.com\/linuxhint"],"@id":"https:\/\/linuxhint.com\/#organization","name":"Linux Hint","logo":"http:\/\/linuxhint.com\/wp-content\/uploads\/2017\/11\/LinuxProfile.png"}</script>

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Linux Hint &raquo; Feed" href="https://linuxhint.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Linux Hint &raquo; Comments Feed" href="https://linuxhint.com/comments/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/linuxhint.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.8"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='spacexchimp_p005-bootstrap-tooltip-css-css' href='https://linuxhint.com/wp-content/plugins/social-media-buttons-toolbar/inc/lib/bootstrap-tooltip/bootstrap-tooltip.css?ver=4.40' type='text/css' media='all' />
<link rel='stylesheet' id='spacexchimp_p005-frontend-css-css' href='https://linuxhint.com/wp-content/plugins/social-media-buttons-toolbar/inc/css/frontend.css?ver=4.40' type='text/css' media='all' />
<style id='spacexchimp_p005-frontend-css-inline-css' type='text/css'>

                    .sxc-follow-buttons {
                        text-align: center !important;
                    }
                    .sxc-follow-buttons li img {
                        width: 64px !important;
                        height: 64px !important;
                        margin: 5px !important;
                    }
                  
</style>
<link rel='stylesheet' id='vce_font_0-css' href='https://fonts.googleapis.com/css?family=Poppins%3A400&#038;subset=latin%2Clatin-ext&#038;ver=2.6' type='text/css' media='screen' />
<link rel='stylesheet' id='vce_style-css' href='https://linuxhint.com/wp-content/themes/voice/css/min.css?ver=2.6' type='text/css' media='screen, print' />
<style id='vce_style-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='vce_child_load_scripts-css' href='https://linuxhint.com/wp-content/themes/voice-child/style.css?ver=2.6' type='text/css' media='screen' />
<link rel='stylesheet' id='meks-author-widget-css' href='https://linuxhint.com/wp-content/plugins/meks-smart-author-widget/css/style.css?ver=1.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='__EPYT__style-css' href='https://linuxhint.com/wp-content/plugins/youtube-embed-plus/styles/ytprefs.min.css?ver=12.0.1' type='text/css' media='all' />
<style id='__EPYT__style-inline-css' type='text/css'>

                .epyt-gallery-thumb {
                        width: 33.333%;
                }
                
</style>
<link rel='stylesheet' id='codecolorer-css' href='https://linuxhint.com/wp-content/plugins/codecolorer/codecolorer.css?ver=0.9.16' type='text/css' media='screen' />
<script type='text/javascript' src='https://linuxhint.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://linuxhint.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://linuxhint.com/wp-content/plugins/social-media-buttons-toolbar/inc/lib/bootstrap-tooltip/bootstrap-tooltip.js?ver=4.40'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _EPYT_ = {"ajaxurl":"https:\/\/linuxhint.com\/wp-admin\/admin-ajax.php","security":"4c3cdbdb9e","gallery_scrolloffset":"20","eppathtoscripts":"https:\/\/linuxhint.com\/wp-content\/plugins\/youtube-embed-plus\/scripts\/","epresponsiveselector":"[\"iframe.__youtube_prefs_widget__\"]","epdovol":"1","version":"12.0.1","evselector":"iframe.__youtube_prefs__[src], iframe[src*=\"youtube.com\/embed\/\"], iframe[src*=\"youtube-nocookie.com\/embed\/\"]","ajax_compat":"","ytapi_load":"light","stopMobileBuffer":"1","vi_active":"","vi_js_posttypes":[]};
/* ]]> */
</script>
<script type='text/javascript' src='https://linuxhint.com/wp-content/plugins/youtube-embed-plus/scripts/ytprefs.min.js?ver=12.0.1'></script>
<link rel='https://api.w.org/' href='https://linuxhint.com/wp-json/' />
<link rel="alternate" type="application/json+oembed" href="https://linuxhint.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Flinuxhint.com%2Finstall_android_virtualbox%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://linuxhint.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Flinuxhint.com%2Finstall_android_virtualbox%2F&#038;format=xml" />

<script type="text/javascript">
_atrk_opts = { atrk_acct:"R7+fr1O7kI20L7", domain:"linuxhint.com",dynamic: true};
(function() { var as = document.createElement('script'); as.type = 'text/javascript'; as.async = true; as.src = "https://certify-js.alexametrics.com/atrk.js"; var s = document.getElementsByTagName('script')[0];s.parentNode.insertBefore(as, s); })();
</script>
<noscript><img src="https://certify.alexametrics.com/atrk.gif?account=R7+fr1O7kI20L7" style="display:none" height="1" width="1" alt="" /></noscript>

<meta name="onesignal" content="wordpress-plugin" />
<link rel="manifest" href="https://linuxhint.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/manifest.json.php?gcm_sender_id=" />
<script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async></script> <script>

      window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
        OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
        OneSignal.SERVICE_WORKER_PARAM = { scope: '/' };

        OneSignal.setDefaultNotificationUrl("https://linuxhint.com");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = '16b01fcf-eb14-4411-8b7c-9a1fad32d447';
oneSignal_options['autoRegister'] = true;
oneSignal_options['httpPermissionRequest'] = { };
oneSignal_options['httpPermissionRequest']['enable'] = true;
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['title'] = "";
oneSignal_options['welcomeNotification']['message'] = "";
oneSignal_options['path'] = "https://linuxhint.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "web.onesignal.auto.66c6cf5f-f4e2-4fcc-bb6d-d84762ec1541";
oneSignal_options['promptOptions'] = { };
oneSignal_options['notifyButton'] = { };
oneSignal_options['notifyButton']['enable'] = true;
oneSignal_options['notifyButton']['position'] = 'bottom-right';
oneSignal_options['notifyButton']['theme'] = 'default';
oneSignal_options['notifyButton']['size'] = 'medium';
oneSignal_options['notifyButton']['prenotify'] = true;
oneSignal_options['notifyButton']['showCredit'] = true;
oneSignal_options['notifyButton']['text'] = {};
              OneSignal.init(window._oneSignalInitOptions);
                    });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }
    </script>

<style type="text/css" id="syntaxhighlighteranchor"></style>
<link rel="shortcut icon" href="https://linuxhint.com/wp-content/uploads/2017/07/website_favicon_1.png" type="image/x-icon" /><style type="text/css">div#wpbody a { color: #0000FF; } div#wpbody a:visited { color: #0000FF; } h1.entry-title { font-size: 38px; font-weight: bold; } h1 { font-size: 34px; font-weight: bold; } h2 { font-size: 28px; font-weight: bold; } h3 { font-size: 26px; font-weight: bold; } h4{ font-weight: bold; } .codecolorer, .codecolorer *, .codecolorer-container, .codecolorer-container * { font: 1.3rem/1.3rem Monaco, Lucida Console, monospace ! important; } .comment-form { margin-bottom: inherit; } .gglcptch_v1, .gglcptch_v2 { text-align: -webkit-right; } pre { background: #36363e; font-family: 'Poppins'; font-size: 14px; color: floralwhite; } .apsc-theme-1 .apsc-each-profile { margin: 3px; } input[type=text] { background: #fff; } div#wpbody { font-family: 'Arimo', sans-serif; font-weight: 400; font-size: 1.14286em; } div#wpbody blockquote { font-family: 'Arimo', sans-serif; font-weight: 400; font-size: 0.8em; font-style: italic; font-weight: bold; } div#newshl a { color: #000000; font-family: 'Arimo', sans-serif; font-weight: 400; font-size: 1.14286em; text-decoration: underline; } div#newshl a:visited { color: #000000; font-family: 'Arimo', sans-serif; font-weight: 400; font-size: 1.14286em; text-decoration: underline; }</style>
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-2559550-13"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments)};
  gtag('js', new Date());

  gtag('config', 'UA-2559550-13');
</script> <style type="text/css" id="wp-custom-css">
			/*
You can add your own CSS here.

Click the help icon above to learn more.
*/
h1 {
font-size:25px;
color: #ba3925;}
h2 {
font-size:22px;
color: #ba3925;
opacity:0.9;}
h3 {
font-size:20px;
color: #ba3925;
}
h4 {
font-size:18px;
color: #ba3925;
opacity:0.9;}
h5 {
font-size:15px;
color: #ba3925;}
h6 {
font-size:12px;
color: #ba3925;}
@media only screen and (max-width: 1200px){
.codecolorer-container, .codecolorer {
max-width: 100%;
	}
}
@media only screen and (max-width: 1000px){
.main-header {
margin-bottom: 100px;
	}
}
@media only screen and (max-width: 1000px){
 .vce-header-ads {
   display: block !important;
   max-width: 100%;
	 text-align:center;
	}
}
		</style>
<script data-cfasync="false" type="text/javascript">window.google_analytics_uacct = "UA-115914608-13";</script>
<script data-cfasync="false" type="text/javascript">
var _gaq = _gaq || [];
_gaq.push(['e._setAccount', 'UA-115914608-13']);
_gaq.push(['f._setAccount', 'UA-38339005-1']);
_gaq.push(['e._setDomainName', 'linuxhint.com']);
_gaq.push(['f._setDomainName', 'linuxhint.com']);
_gaq.push(['e._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['e._setCustomVar',2,'t','126',3]);
_gaq.push(['e._setCustomVar',3,'rid','0',2]);
_gaq.push(['e._setCustomVar',4,'bra','mod6',3]);
_gaq.push(['e._setAllowAnchor',true]);
_gaq.push(['e._setSiteSpeedSampleRate', 10]);
_gaq.push(['f._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['f._setCustomVar',2,'domain','linuxhint.com',3]);
_gaq.push(['f._setSiteSpeedSampleRate', 20]);
_gaq.push(['e._trackPageview']);
_gaq.push(['f._trackPageview']);


(function() {
 var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
 ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
 var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
})();
</script>
<script type="text/javascript">var ezouid = "1";</script><base href="https://linuxhint.com/install_android_virtualbox/"><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script>
<script type='text/javascript'>
var soc_app_id = '0';
var did = 66477;
var ezdomain = 'linuxhint.com';
var ezoicSearchable = 1;
</script>


<script type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":66477,"engaged_time_visit":0,"ezcache_level":1,"forensiq_score":-1,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"47c206e6-78f4-4adc-5d63-151e4c58d01f","postal_code":"20149","pv_event_count":0,"response_time_orig":172,"serverid":"18.208.199.118:10343","state":"VA","t_epoch":1533617492,"template_id":126,"time_on_site_visit":0,"url":"https://linuxhint.com/install_android_virtualbox/","user_id":0,"word_count":1325};var _ezExtraQueries = "&ez_orig=1";</script><script data-cfasync='false' type="text/javascript" src="/detroitchicago/rochester.js?cb=177-0&v=8" async></script><script data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl() {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_66477=" + new Date().getTime() + "|47c206e6-78f4-4adc-5d63-151e4c58d01f; " + expires, 3);
}
function attach_ezolpl() {
    if(window.attachEvent) {
        window.attachEvent('onload', create_ezolpl);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl();
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl;
        }
    }
}
attach_ezolpl();
</script></head>
<body class="post-template-default single single-post postid-29071 single-format-standard chrome vce-sid-right">

<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-P6XN5Z6"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>

<div id="vce-main">
<header id="header" class="main-header">
<div class="container header-2-wrapper header-main-area">
<div class="vce-res-nav">
<a class="vce-responsive-nav" href="#sidr-main"><i class="fa fa-bars"></i></a>
</div>
<div class="site-branding">
<span class="site-title">
<a href="https://linuxhint.com/" title="Linux Hint" class="has-logo"><img src="https://linuxhint.com/wp-content/uploads/2017/07/website_logo_1.png" alt="Linux Hint" /></a>
</span>
</div>
<div class="vce-header-ads">

<div id='ezoic-pub-ad-placeholder-101'><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-4384422059592745" data-ad-slot="5958433459" data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
 </div>
</div>
<div class="header-bottom-wrapper header-left-nav">
<div class="container">
<nav id="site-navigation" class="main-navigation" role="navigation">
<ul id="vce_main_navigation_menu" class="nav-menu"><li id="menu-item-18534" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-18534"><a href="https://linuxhint.com">Home</a><li id="menu-item-27255" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-27255"><a href="https://linuxhint.com/tag/reviews/">Reviews</a><li id="menu-item-28744" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28744"><a href="https://support.linuxhint.com/">Support</a><li id="menu-item-19816" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19816"><a href="https://linuxhint.com/subscribe-to-linuxhint-com/">Subscribe!</a><li id="menu-item-23466" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23466"><a href="https://linuxhint.com/policies-and-privacy/">Policies &#038; Privacy</a><li class="search-header-wrap"><a class="search_header" href="javascript:void(0)"><i class="fa fa-search"></i></a><ul class="search-header-form-ul"><li><form class="search-header-form" action="https://linuxhint.com/" method="get">
<input name="s" class="search-input" size="20" type="text" value="Type here to search..." onfocus="(this.value == 'Type here to search...') && (this.value = '')" onblur="(this.value == '') && (this.value = 'Type here to search...')" placeholder="Type here to search..." /></form></li></ul></li></ul></nav> </div>
</div>
</header>
<div id="main-wrapper">
<div class="vce-ad-below-header vce-ad-container">
<div id="ezoic-pub-ad-placeholder-109"></div>
</div>
<div id="content" class="container site-content vce-sid-right">
<div id="primary" class="vce-main-content">
<main id="main" class="main-box main-box-single">
<article id="post-29071" class="vce-single post-29071 post type-post status-publish format-standard has-post-thumbnail hentry category-android category-virtualbox">
<header class="entry-header">
<span class="meta-category"><a href="https://linuxhint.com/android/" class="category-1331">Android</a> <span>&bull;</span> <a href="https://linuxhint.com/virtualbox/" class="category-1543">VirtualBox</a></span>
<h1 class="entry-title">Installing Android on VirtualBox</h1>
<div class="entry-meta"><div class="meta-item date"><span class="updated">3 days ago</span></div><div class="meta-item author"><span class="vcard author"><span class="fn">by <a href="https://linuxhint.com/author/sranvir155/">Ranvir Singh</a></span></span></div></div>
</header>
<div class="vce-ad vce-ad-container">
<div id="ezoic-pub-ad-placeholder-111"></div>
</div>
<div class="vce-ad vce-ad-container">
<div id="ezoic-pub-ad-placeholder-107">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-4384422059592745" data-ad-slot="9772122209" data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
</div>
<div class="entry-content">
<div id="wpbody">
If you are developing mobile apps Android can be a bit of a hassle. While iOS comes with its niceties, provided you are using macOS, Android comes with just Android Studio which is designed to support more than a few Android version, including wearables.</p><div class="LlrjodAC" style="clear:both;float:left;width:100%;margin:0 0 20px 0;">
<div id="ezoic-pub-ad-placeholder-115"></div>
</div>
<p>Needless to say, all the binaries, SDKs, frameworks and debuggers are going to pollute your filesystem with lots and lots of files, logs and other miscellaneous objects. An efficient work around for this is installing Android on your VirtualBox which takes away one of the sluggiest aspect of Android development &#8212; The device emulator. You can use this VM to run your test application or just fiddle with Android’s internals. So without further ado let’s set on up!</p><div class="2QlpKuQU" style="clear:both;float:left;width:100%;margin:0 0 20px 0;">
<div id="ezoic-pub-ad-placeholder-116"></div>
</div>
<h1>Getting Started</h1>
<p>To get started we will need to have VirtualBox installed on our system, you can get a copy for Windows, macOS or any major distro of Linux <a href="https://www.virtualbox.org/wiki/Downloads">here</a>. Next you would need a copy of Android meant to run on x86 hardware, because that’s what VirtualBox is going to offer to a Virtual Machine an x86 or an x86_64 (a.k.a AMD64) platform to run.</p><div class="I3MDqdH8" style="clear:both;float:left;width:100%;margin:0 0 20px 0;">
<div id="ezoic-pub-ad-placeholder-117"></div>
</div>
<p>While most Android devices run on ARM, we can take help of the project <a href="http://www.android-x86.org/">Android on x86</a>. These fine folks have ported Android to run on x86 hardware (both real and virtual) and we can get a copy of the latest release candidate (Android 7.1) for our purposes. You may prefer using a more stable release but in that case Android 6.0 is about as latest as you can get, at the time of this writing.</p>
<h2>Creating VM</h2>
<p>Open VirtualBox and click on “New” (top-left corner) and in the Create Virtual Machine window select the type to be Linux and version Linux 2.6 / 3.x /4.x (64-bit) or (32-bit) depending upon whether the ISO you downloaded was x86_64 or x86 respectively.</p>
<p>RAM size could be anywhere from 2 GB to as much as your system resources can allow. Although if you want to emulate real world devices you should allocate upto 6GB for memory and 32GB for disk size which are typical in Android devices.</p>
<p><img class="size-full wp-image-29073 aligncenter" src="https://linuxhint.com/wp-content/uploads/2018/08/a.png" alt="" width="527" height="472" srcset="https://linuxhint.com/wp-content/uploads/2018/08/a.png 527w, https://linuxhint.com/wp-content/uploads/2018/08/a-300x269.png 300w" sizes="(max-width: 527px) 100vw, 527px" /></p>
<p><img class="size-full wp-image-29074 aligncenter" src="https://linuxhint.com/wp-content/uploads/2018/08/a1.png" alt="" width="513" height="463" srcset="https://linuxhint.com/wp-content/uploads/2018/08/a1.png 513w, https://linuxhint.com/wp-content/uploads/2018/08/a1-300x271.png 300w" sizes="(max-width: 513px) 100vw, 513px" /></p>
<p>Upon creation, you might want to tweak a few additional settings, add in an additional processor core and improve display memory for starters. To do this, right-click on the VM and open up settings. In the Settings → System → Processor section you can allocate a few more cores if your desktop can pull it off.</p>
<p><img class="aligncenter size-full wp-image-29075" src="https://linuxhint.com/wp-content/uploads/2018/08/a2.png" alt="" width="647" height="444" srcset="https://linuxhint.com/wp-content/uploads/2018/08/a2.png 647w, https://linuxhint.com/wp-content/uploads/2018/08/a2-300x206.png 300w, https://linuxhint.com/wp-content/uploads/2018/08/a2-145x100.png 145w, https://linuxhint.com/wp-content/uploads/2018/08/a2-380x260.png 380w" sizes="(max-width: 647px) 100vw, 647px" /></p>
<p>And in Settings → Display → Video Memory you can allocate a decent chunk of memory and enable 3D acceleration for a more responsive experience.</p>
<p><img class="aligncenter size-full wp-image-29076" src="https://linuxhint.com/wp-content/uploads/2018/08/a3.png" alt="" width="647" height="444" srcset="https://linuxhint.com/wp-content/uploads/2018/08/a3.png 647w, https://linuxhint.com/wp-content/uploads/2018/08/a3-300x206.png 300w, https://linuxhint.com/wp-content/uploads/2018/08/a3-145x100.png 145w, https://linuxhint.com/wp-content/uploads/2018/08/a3-380x260.png 380w" sizes="(max-width: 647px) 100vw, 647px" /></p>
<p>Now we are ready to boot the VM.</p>
<h3>Installing Android</h3>
<p>Starting the VM for the first time, VirtualBox will insist you to supply it with a bootable media. Select the Android iso that you previously downloaded to boot the machine of with.</p>
<p><img class="aligncenter size-full wp-image-29077" src="https://linuxhint.com/wp-content/uploads/2018/08/a4.png" alt="" width="641" height="554" srcset="https://linuxhint.com/wp-content/uploads/2018/08/a4.png 641w, https://linuxhint.com/wp-content/uploads/2018/08/a4-300x259.png 300w" sizes="(max-width: 641px) 100vw, 641px" /></p>
<p>Next, select the Installation option if you wish to install Android on the VM for a long term use, otherwise feel free to log into the live media and play around with the environment.</p>
<p><img class="aligncenter size-full wp-image-29078" src="https://linuxhint.com/wp-content/uploads/2018/08/a5.png" alt="" width="642" height="554" srcset="https://linuxhint.com/wp-content/uploads/2018/08/a5.png 642w, https://linuxhint.com/wp-content/uploads/2018/08/a5-300x259.png 300w" sizes="(max-width: 642px) 100vw, 642px" /></p>
<p>Hit &lt;Enter&gt;.</p>
<h3>Partitioning the Drive</h3>
<p>Partitioning is done using a textual interface, which means we don’t get the niceties of a GUI and we will have to use the follow careful at what is being shown on the screen. For example, in the first screen when no partition has been created and just a raw (virtual) disk is detected you will see the following.</p>
<p><img class="aligncenter size-full wp-image-29079" src="https://linuxhint.com/wp-content/uploads/2018/08/a6.png" alt="" width="722" height="474" srcset="https://linuxhint.com/wp-content/uploads/2018/08/a6.png 722w, https://linuxhint.com/wp-content/uploads/2018/08/a6-300x197.png 300w" sizes="(max-width: 722px) 100vw, 722px" /></p>
<p>The red lettered C and D indicates that if you hit the key <em>C </em>you can create or modify partitions and <em>D </em>will detect additional devices. You can press <em>D </em>and the live media will detect the disks attached, but that is optional since it did a check during the boot.</p>
<p>Let’s hit <em>C </em>and create partitions in the virtual disk. The offical page recommends against using GPT so we will not use that scheme. Select No using the arrow keys and hit <em>&lt;Enter&gt;.</em></p>
<p><img class="aligncenter size-full wp-image-29080" src="https://linuxhint.com/wp-content/uploads/2018/08/a7.png" alt="" width="722" height="474" srcset="https://linuxhint.com/wp-content/uploads/2018/08/a7.png 722w, https://linuxhint.com/wp-content/uploads/2018/08/a7-300x197.png 300w" sizes="(max-width: 722px) 100vw, 722px" /></p>
<p>And now you will be ushered into the fdisk utility.</p>
<p><img class="aligncenter size-full wp-image-29081" src="https://linuxhint.com/wp-content/uploads/2018/08/a8.png" alt="" width="722" height="474" srcset="https://linuxhint.com/wp-content/uploads/2018/08/a8.png 722w, https://linuxhint.com/wp-content/uploads/2018/08/a8-300x197.png 300w" sizes="(max-width: 722px) 100vw, 722px" /></p>
<p>We will create just a single giant partition so as to keep things simple. Using arrow keys navigate to the <em>New </em>option and hit <em>&lt;Enter&gt;. </em> Select primary as the type of partition, and hit <em>&lt;Enter&gt; </em>to confirm</p>
<p><img class="aligncenter size-full wp-image-29082" src="https://linuxhint.com/wp-content/uploads/2018/08/a9.png" alt="" width="722" height="474" srcset="https://linuxhint.com/wp-content/uploads/2018/08/a9.png 722w, https://linuxhint.com/wp-content/uploads/2018/08/a9-300x197.png 300w" sizes="(max-width: 722px) 100vw, 722px" /></p>
<p>The maximum size will already be selected for you, hit <em>&lt;Enter&gt; </em>to confirm that.</p>
<p><img class="aligncenter size-full wp-image-29083" src="https://linuxhint.com/wp-content/uploads/2018/08/a10.png" alt="" width="722" height="474" srcset="https://linuxhint.com/wp-content/uploads/2018/08/a10.png 722w, https://linuxhint.com/wp-content/uploads/2018/08/a10-300x197.png 300w" sizes="(max-width: 722px) 100vw, 722px" /></p>
<p>This partition is where Android OS will reside, so of course we want it to be bootable. So select <em>Bootable </em>and hit enter (Boot will appear in the flags section in the table above) and then you can navigate to the Write section and hit <em>&lt;Enter&gt; </em>to write the changes to the partitioning table.</p>
<p><img class="aligncenter size-full wp-image-29084" src="https://linuxhint.com/wp-content/uploads/2018/08/a11.png" alt="" width="722" height="474" srcset="https://linuxhint.com/wp-content/uploads/2018/08/a11.png 722w, https://linuxhint.com/wp-content/uploads/2018/08/a11-300x197.png 300w" sizes="(max-width: 722px) 100vw, 722px" /></p>
<p>Then you can <em>Quit </em>the partitioning utility and move on with the installation.</p>
<p><img class="aligncenter size-full wp-image-29085" src="https://linuxhint.com/wp-content/uploads/2018/08/a12.png" alt="" width="722" height="474" srcset="https://linuxhint.com/wp-content/uploads/2018/08/a12.png 722w, https://linuxhint.com/wp-content/uploads/2018/08/a12-300x197.png 300w" sizes="(max-width: 722px) 100vw, 722px" /></p>
<h3>Formatting with Ext4 and installing Android</h3>
<p>A new partition will come in the <em>Choose Partition </em>menu where we were before we down the partitioning digression. Let’s select this partition and hit <em>OK</em>.</p>
<p><img class="aligncenter size-full wp-image-29086" src="https://linuxhint.com/wp-content/uploads/2018/08/a13.png" alt="" width="722" height="474" srcset="https://linuxhint.com/wp-content/uploads/2018/08/a13.png 722w, https://linuxhint.com/wp-content/uploads/2018/08/a13-300x197.png 300w" sizes="(max-width: 722px) 100vw, 722px" /></p>
<p>Select ext4 as the de facto file system in the next menu. Confirm the changes in the next window by selecting <strong><em>Yes</em></strong> and the formatting will begin. When asked, say <strong><em>Yes</em></strong> to the GRUB boot loader installation. Similarly, say <strong><em>Yes </em></strong>to allowing read-write operations on the <em>/system </em>directory. Now the installation will begin.</p>
<p>Once it is installed, you can safely reboot the system when prompted to reboot. You may have to power down the machine before the next reboot happens, go to Settings → Storage and remove the android iso if it is still attached to the VM.</p>
<p><img class="aligncenter size-full wp-image-29087" src="https://linuxhint.com/wp-content/uploads/2018/08/a14.png" alt="" width="797" height="447" srcset="https://linuxhint.com/wp-content/uploads/2018/08/a14.png 797w, https://linuxhint.com/wp-content/uploads/2018/08/a14-300x168.png 300w, https://linuxhint.com/wp-content/uploads/2018/08/a14-768x431.png 768w" sizes="(max-width: 797px) 100vw, 797px" /></p>
<p>Remove the media and save the changes, before starting up the VM.</p>
<h3>Running Android</h3>
<p>In the GRUB menu you will get options for running the OS in debug mode or the normal way. Let’s take a tour of Android in a VM using the default option, as shown below:</p>
<p><img class="aligncenter size-full wp-image-29088" src="https://linuxhint.com/wp-content/uploads/2018/08/a16.png" alt="" width="722" height="474" srcset="https://linuxhint.com/wp-content/uploads/2018/08/a16.png 722w, https://linuxhint.com/wp-content/uploads/2018/08/a16-300x197.png 300w" sizes="(max-width: 722px) 100vw, 722px" /></p>
<p>And if everything works fine, you will see this:</p>
<p><img class="aligncenter size-full wp-image-29089" src="https://linuxhint.com/wp-content/uploads/2018/08/a17.png" alt="" width="1023" height="842" srcset="https://linuxhint.com/wp-content/uploads/2018/08/a17.png 1023w, https://linuxhint.com/wp-content/uploads/2018/08/a17-300x247.png 300w, https://linuxhint.com/wp-content/uploads/2018/08/a17-768x632.png 768w, https://linuxhint.com/wp-content/uploads/2018/08/a17-810x667.png 810w" sizes="(max-width: 1023px) 100vw, 1023px" /></p>
<p>Now Android uses touch screen as an interface instead of a mouse, as far as its normal use is concerned. While the x86 port does come with a mouse point-and-click support you may have to use arrow keys a lot in the beginning.</p>
<p><img class="aligncenter size-full wp-image-29090" src="https://linuxhint.com/wp-content/uploads/2018/08/a18.png" alt="" width="1026" height="842" srcset="https://linuxhint.com/wp-content/uploads/2018/08/a18.png 1026w, https://linuxhint.com/wp-content/uploads/2018/08/a18-300x246.png 300w, https://linuxhint.com/wp-content/uploads/2018/08/a18-768x630.png 768w, https://linuxhint.com/wp-content/uploads/2018/08/a18-1024x840.png 1024w, https://linuxhint.com/wp-content/uploads/2018/08/a18-810x665.png 810w" sizes="(max-width: 1026px) 100vw, 1026px" /></p>
<p>Navigate to let’s go, and hit enter, if you are using arrow keys and then select <em>Setup as New.</em></p>
<p><img class="aligncenter size-full wp-image-29091" src="https://linuxhint.com/wp-content/uploads/2018/08/a19.png" alt="" width="1026" height="842" srcset="https://linuxhint.com/wp-content/uploads/2018/08/a19.png 1026w, https://linuxhint.com/wp-content/uploads/2018/08/a19-300x246.png 300w, https://linuxhint.com/wp-content/uploads/2018/08/a19-768x630.png 768w, https://linuxhint.com/wp-content/uploads/2018/08/a19-1024x840.png 1024w, https://linuxhint.com/wp-content/uploads/2018/08/a19-810x665.png 810w" sizes="(max-width: 1026px) 100vw, 1026px" /></p>
<p>It will check for updates and device info, before asking you to sign in using a Google account. You can skip this if you want and move on to setting up Data and Time and give your username to the device after that.</p>
<p>A few other options would be presented, similar to the options you see when setting up a new Android device. Select appropriate options for privacy, updates, etc and of course Terms of Service, which we might have to Agree to.</p>
<p><img class="aligncenter size-full wp-image-29092" src="https://linuxhint.com/wp-content/uploads/2018/08/a20.png" alt="" width="1028" height="842" srcset="https://linuxhint.com/wp-content/uploads/2018/08/a20.png 1028w, https://linuxhint.com/wp-content/uploads/2018/08/a20-300x246.png 300w, https://linuxhint.com/wp-content/uploads/2018/08/a20-768x629.png 768w, https://linuxhint.com/wp-content/uploads/2018/08/a20-1024x839.png 1024w, https://linuxhint.com/wp-content/uploads/2018/08/a20-810x663.png 810w" sizes="(max-width: 1028px) 100vw, 1028px" /></p>
<p>After this, it may ask you to add another email account or set up “On-body detection” since it is a VM, neither of the options are of much use to us and we can click on “All Set”</p>
<p>It would ask you to select Home App after that, which is upto you to decide, as it is a matter of Preference and you will finally be in a virtualized Android system.</p>
<p><img class="aligncenter size-full wp-image-29093" src="https://linuxhint.com/wp-content/uploads/2018/08/a21.png" alt="" width="1028" height="842" srcset="https://linuxhint.com/wp-content/uploads/2018/08/a21.png 1028w, https://linuxhint.com/wp-content/uploads/2018/08/a21-300x246.png 300w, https://linuxhint.com/wp-content/uploads/2018/08/a21-768x629.png 768w, https://linuxhint.com/wp-content/uploads/2018/08/a21-1024x839.png 1024w, https://linuxhint.com/wp-content/uploads/2018/08/a21-810x663.png 810w" sizes="(max-width: 1028px) 100vw, 1028px" /></p>
<p>You may benefit greatly from a touch screen laptop if you desire to do some intensive testing on this VM, since that would emulate a real world use case much closely.</p>
<p>Hope you have found this tutorial useful in case, you have any other similar request for us to write about, please feel free to reach out to us.
</p></div>

<div id="ezoic-pub-ad-placeholder-123"></div>
</p> </div>
<footer class="entry-footer">
<div class="meta-tags">
</div>
</footer>
<div class="vce-ad vce-ad-container">
<div id="ezoic-pub-ad-placeholder-108">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-4384422059592745" data-ad-slot="3070982486" data-ad-format="link"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
</div>
</article>
</main>
<section class="main-box mbt-border-top author-box">
<h3 class="main-box-title">About the author</h3>
<div class="main-box-inside">
<div class="data-image">
<img src="https://linuxhint.com/wp-content/uploads/2018/01/IMG_20171208_193954585-150x150.jpg" width="112" height="112" alt="Ranvir Singh" class="avatar avatar-112 wp-user-avatar wp-user-avatar-112 alignnone photo" /> </div>
<div class="data-content">
<h4 class="author-title">Ranvir Singh</h4>
<div class="data-entry-content">
<p>I am a tech and science writer with quite a diverse range of interests. A strong believer of the Unix philosophy. Few of the things I am passionate about include system administration, computer hardware and physics.</p>
</div>
</div>
</div>
<div class="vce-content-outside">
<div class="data-links">
<a href="https://linuxhint.com/author/sranvir155/" class="vce-author-link vce-button">View all posts</a>
</div>
<div class="vce-author-links">
</div>
</div>
</section>
</div>
<aside id="sidebar" class="sidebar right">
<div id="text-4" class="widget widget_text"><h4 class="widget-title">FOLLOW US</h4> <div class="textwidget">
<ul class="sxc-follow-buttons">
<li>
<a href="https://www.facebook.com/linuxhint1" title="Facebook">
<img src="https://linuxhint.com/wp-content/plugins/social-media-buttons-toolbar/inc/img/social-media-icons/facebook.png" alt="Facebook" />
</a>
</li>
<li>
<a href="https://twitter.com/linuxhint" title="Twitter">
<img src="https://linuxhint.com/wp-content/plugins/social-media-buttons-toolbar/inc/img/social-media-icons/twitter.png" alt="Twitter" />
</a>
</li>
<li>
<a href="https://www.youtube.com/c/linuxhint" title="YouTube">
<img src="https://linuxhint.com/wp-content/plugins/social-media-buttons-toolbar/inc/img/social-media-icons/youtube.png" alt="YouTube" />
</a>
</li>
<li>
<a href="https://linuxhint.com/subscribe-to-linuxhint-com/" title="Email">
<img src="https://linuxhint.com/wp-content/plugins/social-media-buttons-toolbar/inc/img/social-media-icons/email.png" alt="Email" />
</a>
</li>
<li>
 <a href="https://linuxhint.com/feed/" title="RSS Feed">
<img src="https://linuxhint.com/wp-content/plugins/social-media-buttons-toolbar/inc/img/social-media-icons/rss-feed.png" alt="RSS Feed" />
</a>
</li>
</ul>
</div>
</div><div class="vce-sticky"><div id="vce_adsense_widget-3" class="widget vce_adsense_widget vce_adsense_expand"> <div class="vce_adsense_wrapper">

<div id="ezoic-pub-ad-placeholder-102">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-4384422059592745" data-ad-slot="6927656384" data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
 </div>
</div></div> </aside>
</div>
<div class="vce-ad-above-footer vce-ad-container">
<div id="ezoic-pub-ad-placeholder-110"></div>
</div>
<footer id="footer" class="site-footer">
<div class="container">
<div class="container-fix">
<div class="bit-1">
<div id="text-5" class="widget widget_text"> <div class="textwidget"><p></p>
<div id="ezoic-pub-ad-placeholder-106"></div>
<p></p>
</div>
</div> </div>
</div>
</div>
<div class="container-full site-info">
<div class="container">
</div>
</div>
</footer>
</div>
</div>
<a href="javascript:void(0)" id="back-top"><i class="fa fa-angle-up"></i></a>
<script type='text/javascript'>
/* <![CDATA[ */
var vce_js_settings = {"sticky_header":"","sticky_header_offset":"700","sticky_header_logo":"","logo":"https:\/\/linuxhint.com\/wp-content\/uploads\/2017\/07\/website_logo_1.png","logo_retina":"","logo_mobile":"","logo_mobile_retina":"","rtl_mode":"0","ajax_url":"https:\/\/linuxhint.com\/wp-admin\/admin-ajax.php","ajax_mega_menu":"1","mega_menu_slider":"","mega_menu_subcats":"","lay_fa_grid_center":"","full_slider_autoplay":"","grid_slider_autoplay":"","grid_big_slider_autoplay":"","fa_big_opacity":{"1":"0.5","2":"0.7"},"top_bar_mobile":"1","top_bar_mobile_group":"","top_bar_more_link":"More"};
/* ]]> */
</script>
<script type='text/javascript' src='https://linuxhint.com/wp-content/themes/voice/js/min.js?ver=2.6'></script>
<script type='text/javascript' src='https://linuxhint.com/wp-content/plugins/youtube-embed-plus/scripts/fitvids.min.js?ver=12.0.1'></script>
<script type='text/javascript' src='https://linuxhint.com/wp-includes/js/wp-embed.min.js?ver=4.9.8'></script>
<script>var _comscore=_comscore||[];_comscore.push({c1:"2",c2:"20015427"});(function(){var s=document.createElement("script"),el=document.getElementsByTagName("script")[0];s.async=true;s.src=(document.location.protocol=="https:"?"https://sb":"http://b")+".scorecardresearch.com/beacon.js";el.parentNode.insertBefore(s,el)})();</script><noscript><img src="https://sb.scorecardresearch.com/p?c1=2&c2=20015427&cv=2.0&cj=1"/></noscript>
<script type="text/javascript">var _qevents=_qevents||[];(function(){var elem=document.createElement('script');elem.src=(document.location.protocol=="https:"?"https://secure":"http://edge")+".quantserve.com/quant.js";elem.async=true;elem.type="text/javascript";var scpt=document.getElementsByTagName('script')[0];scpt.parentNode.insertBefore(elem,scpt)})();_qevents.push({qacct:"p-31iz6hfFutd16",labels:"Domain.linuxhint_com,DomainId.66477"});</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.linuxhint_com,DomainId.66477"border="0"height="1"width="1"alt="Quantcast"/></div></noscript>
<script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('edmonton.php', '//linuxhint.com/detroitchicago/edmonton.webp?a=a&cb=0&shcb=30', true, [], true, false, false, false);
__ez.queue.addFile('jellyfish.php', '//linuxhint.com/porpoiseant/jellyfish.webp?a=a&cb=0&shcb=30', false, [], true, false, false, false);
</script>
</body>
</html>